Press "Enter" to skip to content

Pokemon GO Now Available on Updated iOS 14 Devices!

Over the past months, many popular Pokemon GO players had complained about Apple’s iOS 14 beta version. Most of them experienced breaking the game, which resulted in them not being able to play it. However, thanks to the newest update of Apple, players can play the game now! Just in time to capture Mega Pidgeot.

Calling all Pokemon GO players, you can now play your favorite pocket monster game in your newly-updated iOS 14 devices.

More than two months ago, Apple released the iOS 14 developer beta version. Of course, most iPhone users updated their gadgets, but it turns out, the update cannot run the Pokemon GO.

Niantic already released a statement regarding the matter, saying that it does not support any OS beta versions.

Interestingly, on Thursday, Sept. 16, the latest OS version of iOS 14 was made available for most regions across the world.

Unfortunately, the game was still not yet available on the updated version. Game Press even reported that a lot of players of the game demanded Niantic to fix the problem.

“If any of you aren’t aware, iOS 14 is currently still not supported by Pokémon GO, as the game runs into constant crashes and consistently fails to make it past the loading screen,” said by one of the Redditors.

The post added: “For all iOS users: wait to update at least until Niantic pushes out iOS 14 support if you want to make sure your game runs smoothly.”

After a couple of hours, Niantic has successfully repaired the system and allow Pokemon GO on the latest iOS 14. 

Engadget reported that it is okay if players see the Apple version 1.153.0 since once you open the settings in the app after updating, it will show the 0.187 version after. 

Who’s excited to try it now?

ALSO READ: ‘Pokemon GO’ Legendary Boss Raid Guide: How to Defeat Cresselia (Counters & Weaknesses)

This article is owned by Tech Times

Written by Jamie Pancho 

Be First to Comment

Leave a Reply

Your email address will not be published. Required fields are marked *